RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 09-02-2019, 02:26 PM   #1
Saltaholic
Junior Member
 
Join Date: Sep 2019
Location: San Antonio
Posts: 2
Trailer Light question

I have a new to me 2018 Cougar Half Ton 34 bhs. I used it this weekend and noticed while towing if I hit the breaks or turned on the blinkers all the outside safety lights would blink or be solid depending on which I did

I am not sure where to start. Any help or advice would be much appreciated. Thanks!!
__________________

Saltaholic is offline   Reply With Quote
Old 09-02-2019, 02:31 PM   #2
NH_Bulldog
Senior Member
 
NH_Bulldog's Avatar
 
Join Date: Apr 2019
Location: Henniker
Posts: 555
Sounds like a grounding issue
__________________

__________________
Rob & Amy
2019 Passport 240BH SL
2015 Ford F150 3.5L Ecoboost SCrew 4x4 w/Max Tow Pkg
NH_Bulldog is offline   Reply With Quote
Old 09-02-2019, 04:26 PM   #3
Terry W.
Senior Member
 
Terry W.'s Avatar
 
Join Date: Mar 2012
Location: Pickens, SC
Posts: 289
Don't mean to sound like a smart butt but was it plugged in correctly, big flat on top? Is it a factory 7 pin plug on the truck? If not it maybe wired incorrectly?Click image for larger version

Name:	Towing101Chapter7.9.JPG
Views:	82
Size:	71.7 KB
ID:	23523
__________________
https://www.keystonerv.org/forums/pic...pictureid=1416 Terry & Kathy
2012 Avalanche 330RE
2006 F250 Super Crew Chipped, K&N
2-11 Pound 4 Legged Furry Childern
Pickens, SC
Terry W. is offline   Reply With Quote
Old 09-02-2019, 05:03 PM   #4
Saltaholic
Junior Member
 
Join Date: Sep 2019
Location: San Antonio
Posts: 2
Quote:
Originally Posted by Terry W. View Post
Don't mean to sound like a smart butt but was it plugged in correctly, big flat on top? Is it a factory 7 pin plug on the truck? If not it maybe wired incorrectly?Attachment 23523
Yes it was all plugged in correctly. Worked fine the first two times I used it.
Saltaholic is offline   Reply With Quote
Old 09-02-2019, 05:11 PM   #5
Terry W.
Senior Member
 
Terry W.'s Avatar
 
Join Date: Mar 2012
Location: Pickens, SC
Posts: 289
Humm back to thinking. If it worked before first place I would check/ look is the junction box where the cord connects to trailer wiring on the tounge
__________________
https://www.keystonerv.org/forums/pic...pictureid=1416 Terry & Kathy
2012 Avalanche 330RE
2006 F250 Super Crew Chipped, K&N
2-11 Pound 4 Legged Furry Childern
Pickens, SC
Terry W. is offline   Reply With Quote
Old 09-02-2019, 05:31 PM   #6
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 19,607
It sounds to me like a tail/brake light bulb is "grounded"... Take the covers off the tail lights, make sure the bulbs are properly seated. They are 1157 bulbs and they are easy to "jiggle out of the socket" and ground out. When that happens, the tail/running lights will light when the brakes/turn signal is powered on.....
__________________

__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Reply

Tags
light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 05:58 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×