RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-08-2018, 06:11 AM   #1
Kellysingleton
Junior Member
 
Join Date: May 2017
Location: Cincinnati
Posts: 8
Post Extremely Loud Water Pump

I have a 2017 Hideout. It has been on approximately 9 total weekend+ trips. I bought it beand new. The guy giving me the tutorial said the waterpump would make a noise when first starting up. Last year, the noise (after start up) would go all the time but it wasnt annoying. Since de-winterization, the water pump literally groans long and loud, my neighbors on the next campsite over made a remark about it.

Does anyone else have this issue? Is the loud groan normal? I dont "hear" anyone elses pumps.

PS. This is my first camper.
__________________

Kellysingleton is offline   Reply With Quote
Old 07-08-2018, 06:29 AM   #2
flybouy
Site Team
 
Join Date: Oct 2011
Location: Joppa, MD
Posts: 5,410
You stste the issue started after dewinterizing. I would suggest checking the water lines at the pump as they may have been disturbed and are now vibrating against a wooden panel or the floor. Also check winterizing valve and make sure pump isn't sucking air with the water
__________________

__________________
Marshall
2012 Laredo 303 TG
2010 F250 LT Super Cab, long bed, 4X4, 6.4 Turbo Diesel
flybouy is offline   Reply With Quote
Old 07-08-2018, 07:52 AM   #3
sourdough
Site Team
 
Join Date: Feb 2014
Location: W. Texas
Posts: 10,532
I agree with flybouy. If this started after dewinterizing then it is probably something that happened during that process. The movement of most anything pertaining to the pump can make the noise worse, and sometimes better. If you relocated one of the lines, even just a bit, and it no touches the outside wall or wall of the enclosure it can make the pump sound terrible...and they're bad enough when working properly.

I'm not sure what you are referring to when you say the pump "would go all the time after startup". Does/did it run constantly? If so, you have an air leak, water leak or pump issue. It should run a while on first startup when it primes. Afterward it should only run when you open a faucet. When you say it "groans"; are you talking about the way it sounds when it runs?
__________________
Danny & Susan wife of 53 years
2019 Ram 3500 Laramie CC SB 6.4 4x4 4.10
2020 Montana High Country 331RL
sourdough is offline   Reply With Quote
Reply

Tags
water, water pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 05:52 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×