Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 10-27-2016, 06:23 AM   #1
jcpippert1997
Junior Member
 
Join Date: Oct 2016
Location: Buena Vista,Co.
Posts: 1
No power

I just purchased a 2017 sprinter campfire 29fk and I am not getting any electricity when I plug into my house or a generator. Any suggestions?
jcpippert1997 is offline   Reply With Quote
Old 10-27-2016, 06:44 AM   #2
bitten
Senior Member
 
Join Date: Apr 2016
Location: Madisonville, ky
Posts: 116
Re: No power

Breakers, battery disconnect, etc
bitten is offline   Reply With Quote
Old 10-27-2016, 06:45 AM   #3
jsmith948
Senior Member
 
Join Date: Jan 2012
Location: Central San Joaguin Valley, CA
Posts: 2,117
Re: No power

Well - first we need a little more info. But this is what I would do: Start at the receptacle. If there is power there, then work downstream to the the trailer panel. If you have power at the plug, but not at the trailer, the cord/connections could be faulty. The main breaker could be bad at the trailer's power panel. My suggestion would be to troubleshoot the various components and then get back to us. If you do not understand ac power, call an electrician.
__________________

Jack & Marty
2018 Laredo 298 SRL
2011 F-250 SB Crew Cab 4x4 6.7L
jsmith948 is offline   Reply With Quote
Old 10-27-2016, 07:42 AM   #4
hankpage
Site Team
 
hankpage's Avatar
 
Join Date: Jun 2009
Location: Venice
Posts: 5,155
Re: No power

Quote:
Originally Posted by jcpippert1997 View Post
I just purchased a 2017 sprinter campfire 29fk and I am not getting any electricity when I plug into my house or a generator. Any suggestions?
Welcome to the family.

As mentioned, a little more info is needed. Are you plugging into a 30 or 50amp source at house or using a 20amp adapter??? Is your trailer 30 or 50amp?????? If it is 50amp and you are using a 20amp adapter you may only be feeding half of your trailer. Make sure all circuit breakers are turned on in the trailer.

Let us know what you find so that you may help someone else with a similar problem, Hank
__________________
Hank & Lynn
2007 Cougar 290RKS, E-Z Flex, 16" XPS RIBs ( SOLD .. Gonna miss her ... looking for new 5r)
2004.5 Dodge 2500 QC, LB, 5.9HO, WestTach gauges, Ride-Rite
hankpage is offline   Reply With Quote
Old 10-27-2016, 05:16 PM   #5
CaptnJohn
Senior Member
 
Join Date: Dec 2015
Location: Ocean Isle Beach
Posts: 1,375
Re: No power

Position of the power disconnect switch?
__________________

2019 Montana 3761 FL
2019 F350 6.7 4X4 DRW

Edgewater 205 EX Yamaha 150
CaptnJohn is offline   Reply With Quote
Old 10-28-2016, 05:21 AM   #6
ctbruce
Site Team
 
ctbruce's Avatar
 
Join Date: Dec 2015
Location: Kansas City
Posts: 3,879
Re: No power

Welcome to the forum from Kansas City, MO! You've got some good people on your post wanting to help. If you solved your problem, let us know and share what worked. That will help someone else down the line.

Chip Bruce, RPh
Kansas City, MO
2016 Fuzion Impact 312
2015 Chevrolet Silverado LTZ
WELL....THAT WAS FUN!
__________________

Chip Bruce, RPh
Kansas City, MO
2016 Impact 312
2017 Silverado 3500HD SRW
ctbruce is offline   Reply With Quote
Old 10-28-2016, 06:55 AM   #7
SAABDOCTOR
Senior Member
 
SAABDOCTOR's Avatar
 
Join Date: Aug 2011
Location: WESTERN,CT
Posts: 2,094
Re: No power

Hi and welcome. this is what i do when diagnosing this type of issue. Start at the source. Do you have power at the plug at your house? if yes plug in the cord and check power at the end that goes into the trailer if it is a plug. got power? yes with it unplugged pull your breaker panel. the plug the cord in. Check for power at the panel. if yes check your breakers. if no call the dealer should be under warranty. Last thought since you have a generator. is yours one you plug your power cord into or built in with a transfer switch? if it has a transfer switch that could be bad (warranty).I am assuming this is a new trailer as you said 2017. if you can post more info that would be very helpful. like did it ever work correctly. Also the plug at your house. is it a ground fault or on a ground fault breaker. I have had mine trip as i was plugging my cord in. good luck let us know how you make out.
__________________
BARNEY AND CHRISTINE
2010 MONTANA 3750FL
2005 DODGE 3500 DUALLY TD
2 RESCUE PUPS: SUSITNA AND CRYSTAL. RIP ALYESKA!
SAABDOCTOR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 03:34 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.