Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-23-2016, 02:32 PM   #1
brh500
Junior Member
 
Join Date: Jul 2016
Location: Berkley, MA
Posts: 4
Power LCI Awning has no power

We have a Cougar 26RBI trailer with an LCI power awning. In setting up at a campground on Cape Cod this weekend, we found that there is no power to the motor. I can't find the circuit breaker to it in order to check if that is the problem and see if it is just tripped (hopefully). Of course, considering the problems we have had with this camper, which we bought brand new, I am not surprised at anything. Anyone know where Keystone hides the breaker, or if there could be something else afoot? The jack and slideouts work, it is only the awning receiving no power.
brh500 is offline   Reply With Quote
Old 07-23-2016, 05:08 PM   #2
BigMac
Junior Member
 
Join Date: Jul 2016
Location: Waterloo, Ontario, Canada
Posts: 8
Sorry to hear brh500. I don't have a lot of help on the issue but am interested in ur comment on the issues you have had. We just bought a new Cougar 28RBS and have a few issues but would like to hear other Cougar ailments.


Sent from my iPad using Tapatalk
BigMac is offline   Reply With Quote
Old 07-23-2016, 05:58 PM   #3
14george
Senior Member
 
14george's Avatar
 
Join Date: Jan 2015
Location: West Virginia
Posts: 1,270
Check fuse in circuit braker panel 12 volt
__________________
Navy 1980-1984
14george is offline   Reply With Quote
Old 07-23-2016, 06:43 PM   #4
brh500
Junior Member
 
Join Date: Jul 2016
Location: Berkley, MA
Posts: 4
The other issues we have had are that the furnace, water pump and radio all had to be replaced, one of the slideout brackets has been repaired twice after pulling from the wall, and the minor one that the outside speaker does not work.
brh500 is offline   Reply With Quote
Old 07-25-2016, 07:33 AM   #5
RavensFan24
Member
 
Join Date: Jun 2015
Location: Hudson, FL
Posts: 41
I had this issue pop up on my '15 30RIPR with the same brand awning. It turns out it wasn't a power issue, but the gears had gotten stuck. I was able to get a 7/16" socket and pop the rubber cap off the top of the awning arm and open it manually using a drill and the socket. Once it started moving, the awning worked via the switch again. Sometimes moisture can cause the gears to get stuck if it's left to sit a while. This happened to me twice, so the 2nd time I sprayed some WD40 in there to try and loosen things up. I hope the next time I grab the trailer from storage that it's not an issue, but at least I know how to fix it now. I had called Lippert and Keystone and they thought it might be an issue with the motor. They were willing to cover it, since I was just outside of my warranty, but luckily it seems to be more of an environmental issue than a mechanical issue. I'm in FL, so there is lots of moisture in the air to muck things up.

Try opening it manually and see if that kick starts things for you.
__________________
2015 Keystone Bullet Premier 30RIPR & 2010 Chevy Tahoe LT Z71

https://forums.goodsamclub.com/Share...205_164040.jpg
RavensFan24 is offline   Reply With Quote
Old 10-30-2016, 02:48 PM   #6
temccarthy1
Junior Member
 
Join Date: Mar 2016
Location: Flemington,NJ
Posts: 27
Re: Power LCI Awning has no power

Wow! That's a lot of trailer for a Tahoe. We have a slightly smaller Bullet, a 2014 285RLS and an Expedition to pull it which is bigger than a Tahoe. How does that rig pull? What kind of cruising speed do you get and milage?
__________________

Tim, Ramona and dog Scruffy
1982 Coleman Sun Valley PUP (retired)
2014 Keystone Bullet Ultralite 285RLS TT
2013 Ford Expedition XLT 5.4L V8 Triton
Equalizer E2 WD Hitch
temccarthy1 is offline   Reply With Quote
Old 10-30-2016, 03:14 PM   #7
14george
Senior Member
 
14george's Avatar
 
Join Date: Jan 2015
Location: West Virginia
Posts: 1,270
Re: Power LCI Awning has no power

Quote:
Originally Posted by brh500 View Post
We have a Cougar 26RBI trailer with an LCI power awning. In setting up at a campground on Cape Cod this weekend, we found that there is no power to the motor. I can't find the circuit breaker to it in order to check if that is the problem and see if it is just tripped (hopefully). Of course, considering the problems we have had with this camper, which we bought brand new, I am not surprised at anything. Anyone know where Keystone hides the breaker, or if there could be something else afoot? The jack and slideouts work, it is only the awning receiving no power.
Did you ever get it fixed
__________________
Navy 1980-1984
14george is offline   Reply With Quote
Old 10-31-2016, 10:08 AM   #8
SAABDOCTOR
Senior Member
 
SAABDOCTOR's Avatar
 
Join Date: Aug 2011
Location: WESTERN,CT
Posts: 2,094
Re: Power LCI Awning has no power

Hi You said there is no ower at the motor. Did you confirm that with a volt meter? or just that it doesn't move?. does it work with the switch? and not with the remote? or both? is the fuse in the fuse box good? it is a 12 volt circut so it will have a blade fuse not a breaker. a blown fuse should have a red led lite lit by the fuse to tell you it blew. so if the fuese are good and the motor has no pwer then look at where the wiring folds with the arms. if all is good then you will needto roll it in manualy and get it looked at. also check the fuse for power maybe the wires at the fuse block were not installed well my camper had some lose wires at the fuse block and two were actually disconected. good luck.
__________________
BARNEY AND CHRISTINE
2010 MONTANA 3750FL
2005 DODGE 3500 DUALLY TD
2 RESCUE PUPS: SUSITNA AND CRYSTAL. RIP ALYESKA!
SAABDOCTOR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV® is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 07:38 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.