RV News RVBusiness 2021 Top 10 RVs of the Year, plus 56 additional debuts and must-see units → ×
 

Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-05-2015, 05:56 AM   #1
Finallyonair
Junior Member
 
Join Date: Jun 2015
Location: Texas
Posts: 9
Bullet 2nd AC

I purchased a bullet 308bhs last weekend. We had the 2nd AC added to the rear as its a 50a setup. The problem I have is it doesn't blow any air....at all. Open the center vent....close the vent... nothing. the blower runs and cycles like it wants to.... but I'm out camping right now and need it to work.... any ideas?
__________________

Finallyonair is offline   Reply With Quote
Old 07-05-2015, 10:58 AM   #2
sourdough
Site Team
 
Join Date: Feb 2014
Location: W. Texas
Posts: 11,230
The blower runs? If it is running I am assuming it's putting out air somewhere. Where is it going? Have you pulled the bottom to check it out?
__________________

sourdough is online now   Reply With Quote
Old 07-05-2015, 11:32 AM   #3
Finallyonair
Junior Member
 
Join Date: Jun 2015
Location: Texas
Posts: 9
That's the question of the day lol. It's blowing. Sounds just like the main unit. It's not connected to any of ceiling vents that I can tell..not sure if it's supposed to be. It has these little "flaps" on each of the 4 sides that look like vents but nothing comes outta there either. I'm going to bring it in tomorrow to figure out what's wrong.
Finallyonair is offline   Reply With Quote
Old 07-05-2015, 01:04 PM   #4
sourdough
Site Team
 
Join Date: Feb 2014
Location: W. Texas
Posts: 11,230
Do you know what kind of AC it is? I'm not sure what all ACs look like on the inside but what you describe sounds a lot like my Dometic Penguin II. Mine vents straight into the bedroom and doesn't use the vent system. Maybe they forgot to duct it into the inside control unit and registers?
sourdough is online now   Reply With Quote
Old 07-12-2015, 04:55 AM   #5
Finallyonair
Junior Member
 
Join Date: Jun 2015
Location: Texas
Posts: 9
They didn't put a divider between the intake and exhaust of the unit when they installed it.
Finallyonair is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 09:43 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×