Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Keystone RV Forums > Welcome to KeystoneForums.com! > New Member Check in!
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 08-25-2010, 04:12 AM   #1
Everest343l
Junior Member
 
Join Date: Aug 2010
Posts: 1
hello everyone

I am new to this site, but we have owned our 2007, 343 L since July of 2006, there were no Keystone dealers in Nova scotia, so we ordered it in the U.S. since then a dealership opened up and when we needed warranty work we were put to the back of the line because we didn't buy it there, parts were ordered, the wrong ones were sent,reordered again, wrong ones sent again,and delays in recieving all the parts. I finally gave up waiting for a roll of boarder ,that had been ordered several times and always the wrong one sent. We have taken our 5th wheel to Florida for 3 winters and each trip there seemed to be problems with screws falling out, the sliding door fell off its track,panelling coming loose, staples falling out of the trim, and the day/night shades come apart because of the strings breaking, now the furnace is not working and the rubber on the roof is starting to bubble in places.The trailer has been very well cared for, only seeing winter for about a month a year and last year we bought an older trailer in Florida because we didn't want to keep towing it and things keep happening to it, so we stored our Everest inside for the winter,now we keep it as a cottage on a piece of property that we have, I take it out now and again to try to keep things from seizing up,we have an 05 Chevy Silverado Duramax 2500 with a Super Chip programer installed we went from 9 mpg to 11.5 mpg and lots of power to maintain highway speeds, and yes my wife drives as well,although she hasn't perfected the backing up part. Thanks for letting me vent my problems, if anyone knows anything about an Atwood 8535-IV furnace I would be greatful to pick their brain about the problem...thanks again TJ.
__________________

Everest343l is offline   Reply With Quote
Old 08-25-2010, 07:54 AM   #2
Festus2
Site Team
 
Join Date: Mar 2009
Location: Fraser Valley BC Canada
Posts: 7,015
Welcome to the forum, TJ. In regards to your furnace question........ If you were to provide us with further details about your Atwood, we might be able to answer your question more easily. For example, has it ever worked? Does the fan run? Fan works but no heat? Nothing happens when you turn the thermostat on? Etc.
I would also recommend that you move your furnace and other questions and responses to the Repairs and Maintainence Section or to some other more appropriate category now that you have introduced yourself.
__________________
2008 Cougar 5th Wheel 27RKS
2005 2500 GMC Duramax
Festus2 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 06:51 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×