Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Keystone RV Forums > Keystone Tech Forums > Keystone Questions
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 05-25-2024, 07:36 AM   #1
winterscold
Junior Member
 
Join Date: May 2024
Location: Ignace
Posts: 1
Angry slide non function

Hey all
I have a 2011 Keystone Retreat 39FDEN...when attempting to activate the slides,the motor begins to operate for about 2 seconds then stops...if I wait a little while and try again the same thing happens.I replaced the motor solenoid
thinking that may have been the problem, but the situation still exists.Does anyone know if there is a relay associated with this system,or what the problem may be?
winterscold is offline   Reply With Quote
Old 05-25-2024, 09:06 AM   #2
LHaven
Senior Member
 
LHaven's Avatar
 
Join Date: Feb 2019
Location: Wickenburg
Posts: 3,398
One possibility is that you have no battery, or a bad battery. Slides and levelers require a battery as a source of fast bulk amperage -- trying to run them exclusively off the converter via shore power often produces this exact behavior.
__________________
2019 Cougar 26RBSWE
2019 Ford F-250
LHaven is offline   Reply With Quote
Reply

Tags
slide

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 01:02 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.