Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 

Go Back   Keystone RV Forums > Keystone Tech Forums > Repairs & Maintenance
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 01-23-2023, 05:01 PM   #1
montana.2018
Junior Member
 
Join Date: Jan 2023
Location: Santa Fe
Posts: 3
interior lights not working

We have a 2018 montana and we recently had to replace the converter due to it not working. We travel full time but when home we plug it at a house. we installed the right plug in and even had an electrician come and look at it. Itís been 4 months since replacing the converter and yet our interior lights are not working again. We leave the batteries connected the whole time. could that be the issue? do we need to turn in the battery disconnect switch?
montana.2018 is offline   Reply With Quote
Old 01-23-2023, 05:59 PM   #2
jsb5717
Senior Member
 
jsb5717's Avatar
 
Join Date: Mar 2019
Location: Milwaukie, OR
Posts: 1,120
Welcome aboard! If the trailer is plugged into shore power, 120v, then the lights should work with or without good batteries if the converter is working correctly.

So check the battery disconnect switch first. If you can pull the key out it's off. It needs to be on so rotate the switch 180 degrees. Check that and let us know if that solves it.
__________________
Jeff & Sandi (and Teddy - 7lb Schnorkie)
2018 Montana High Country 305RL
2012 RAM 3500 Crew Cab 4x4 SRW
Demco Recon Hitch on B&W Turnover Ball
jsb5717 is offline   Reply With Quote
Old 01-30-2023, 10:31 AM   #3
montana.2018
Junior Member
 
Join Date: Jan 2023
Location: Santa Fe
Posts: 3
Hi, so when we turn on the battery disconnect switch everything in the camper stops working. a read on some websites that you can turn the switch to on mode when plugged into shore power it just will not charge the batteries. i read that the switch needed to be off anytime you try to pull your slides in or out, use your jack, and the awning i think but i don’t remember exactly. when i posted the original post we went and bought new batteries and everything was fine for like a week until i woke up today and the lights were dim and got so dim now you can’t even tell they’re on.
montana.2018 is offline   Reply With Quote
Old 01-30-2023, 10:41 AM   #4
jsb5717
Senior Member
 
jsb5717's Avatar
 
Join Date: Mar 2019
Location: Milwaukie, OR
Posts: 1,120
It doesn't make sense that the key in the ON position turns everything OFF. If you can pull the red key out of the battery disconnect then it's OFF. It needs to be ON all the time when the trailer is in use. Make sure the key is "ON" and can't be pulled out. The only time to turn it OFF is when the trailer is in storage.

Make sure the key is ON and let us know if things are working or not
__________________
Jeff & Sandi (and Teddy - 7lb Schnorkie)
2018 Montana High Country 305RL
2012 RAM 3500 Crew Cab 4x4 SRW
Demco Recon Hitch on B&W Turnover Ball
jsb5717 is offline   Reply With Quote
Old 01-30-2023, 11:20 AM   #5
montana.2018
Junior Member
 
Join Date: Jan 2023
Location: Santa Fe
Posts: 3
it is currently in the ON position and has been since we replaced the batteries yes the same thing still happened. i want to say it has been in the on position the entire time and we only switched it off to see if that would help the situation
montana.2018 is offline   Reply With Quote
Old 01-30-2023, 11:47 AM   #6
bobbecky
Senior Member
 
bobbecky's Avatar
 
Join Date: Jul 2013
Location: Box Elder
Posts: 2,463
If things havenít been working since you changed batteries, itís possible that the connections were momentarily wrong when you were making the connections and blew the reverse polarity fuse(s), and that could be why you arenít getting power from the 12 volt system.
__________________
Bob & Becky
2012 3402 Montana
2012 Chevy 2500HD D/A CC
bobbecky is offline   Reply With Quote
Old 01-30-2023, 12:34 PM   #7
jsb5717
Senior Member
 
jsb5717's Avatar
 
Join Date: Mar 2019
Location: Milwaukie, OR
Posts: 1,120
Quote:
Originally Posted by bobbecky View Post
If things havenít been working since you changed batteries, itís possible that the connections were momentarily wrong when you were making the connections and blew the reverse polarity fuse(s), and that could be why you arenít getting power from the 12 volt system.
Yes, make sure you are plugged into shore power. Make sure the battery key is ON. Check the voltage at the batteries to see if you're getting voltage there. Should be ~13.5 volts
__________________
Jeff & Sandi (and Teddy - 7lb Schnorkie)
2018 Montana High Country 305RL
2012 RAM 3500 Crew Cab 4x4 SRW
Demco Recon Hitch on B&W Turnover Ball
jsb5717 is offline   Reply With Quote
Reply

Tags
light, lights

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 04:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2023, vBulletin Solutions, Inc.