Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 

Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Lite Weight Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 04-22-2021, 01:57 PM   #1
Trouble
Junior Member
 
Join Date: Apr 2021
Location: Pinson
Posts: 14
Convenience Center lights

2019 Springdale 1800BH

So this only thing that I have found not working is the lights for the freshwater and grey water levels. Has anyone had this issue? I have not found the pinout for the connections on the circuit board, all connections seem good and i have tested the continuity to the first crimp from the circuit board. just wondering if this is a board issue or a sensor in the tanks??
__________________

Trouble is offline   Reply With Quote
Old 04-22-2021, 02:48 PM   #2
chuckster57
Site Team
 
chuckster57's Avatar
 
Join Date: Jul 2014
Location: Modesto
Posts: 13,621
What do they read?
__________________

__________________

2012 Copper Canyon 273FWRET being towed by a 1994 Ford F350 CC,LB,Dually diesel.
Airlift 5000 bags, Prodigy brake control, 5 gauges on the pillar.Used to tow a '97 Jayco 323RKS.

Now an RVIA registered tech. Retired from Law enforcement in 2008 after 25+ yrs.
chuckster57 is offline   Reply With Quote
Old 04-22-2021, 02:52 PM   #3
Trouble
Junior Member
 
Join Date: Apr 2021
Location: Pinson
Posts: 14
The fresh and grey no lights only black works
Trouble is offline   Reply With Quote
Old 04-22-2021, 03:31 PM   #4
BigBobIa
Member
 
BigBobIa's Avatar
 
Join Date: Feb 2021
Location: Des Moines
Posts: 55
Have you run enough water (gray) or “stuff” (black) to light up the 1/4 full lights?
BigBobIa is offline   Reply With Quote
Old 04-22-2021, 03:35 PM   #5
chuckster57
Site Team
 
chuckster57's Avatar
 
Join Date: Jul 2014
Location: Modesto
Posts: 13,621
Quote:
Originally Posted by Trouble View Post
The fresh and grey no lights only black works
Not even “empty”? Even if the sensors aren’t hooked up, when you press the button on the panel it would read empty.
__________________

2012 Copper Canyon 273FWRET being towed by a 1994 Ford F350 CC,LB,Dually diesel.
Airlift 5000 bags, Prodigy brake control, 5 gauges on the pillar.Used to tow a '97 Jayco 323RKS.

Now an RVIA registered tech. Retired from Law enforcement in 2008 after 25+ yrs.
chuckster57 is offline   Reply With Quote
Old 04-22-2021, 03:44 PM   #6
Trouble
Junior Member
 
Join Date: Apr 2021
Location: Pinson
Posts: 14
I have filled the fresh water and and have ran water to put into the grey tank. Neither of these show any lights
Trouble is offline   Reply With Quote
Old 04-22-2021, 03:50 PM   #7
BigBobIa
Member
 
BigBobIa's Avatar
 
Join Date: Feb 2021
Location: Des Moines
Posts: 55
Convenience Center lights

If the fresh water tank is full and no lights, then you have a problem. May not have enough in gray to turn on a light but fresh is.

Never had this so who can help troubleshooting?
BigBobIa is offline   Reply With Quote
Old 04-22-2021, 03:50 PM   #8
chuckster57
Site Team
 
chuckster57's Avatar
 
Join Date: Jul 2014
Location: Modesto
Posts: 13,621
Ok. If your panel is KIB, you can get the color codes on their website. I would take the black tank lead and swap it with the fresh water lead. Then if the fresh light still doesn’t work it’s the board/light.
__________________

2012 Copper Canyon 273FWRET being towed by a 1994 Ford F350 CC,LB,Dually diesel.
Airlift 5000 bags, Prodigy brake control, 5 gauges on the pillar.Used to tow a '97 Jayco 323RKS.

Now an RVIA registered tech. Retired from Law enforcement in 2008 after 25+ yrs.
chuckster57 is offline   Reply With Quote
Old 04-23-2021, 01:20 PM   #9
Trouble
Junior Member
 
Join Date: Apr 2021
Location: Pinson
Posts: 14
So a bit confused

I have disconnected the three wires which are for the grey fresh and black tanks and the black tank still lights up,

Next i have tried to look the part number for the board with no luck
I will attach pictures here
Attached Thumbnails
Click image for larger version

Name:	20210422_162033.jpg
Views:	16
Size:	135.8 KB
ID:	33145   Click image for larger version

Name:	20210423_161417.jpg
Views:	19
Size:	100.1 KB
ID:	33146  
Trouble is offline   Reply With Quote
Old 04-23-2021, 01:23 PM   #10
chuckster57
Site Team
 
chuckster57's Avatar
 
Join Date: Jul 2014
Location: Modesto
Posts: 13,621
Does the black show empty? If so that’s good.

If you know a holding tank has liquid in it, hook that wire to the fresh and then see what it reads.
__________________

2012 Copper Canyon 273FWRET being towed by a 1994 Ford F350 CC,LB,Dually diesel.
Airlift 5000 bags, Prodigy brake control, 5 gauges on the pillar.Used to tow a '97 Jayco 323RKS.

Now an RVIA registered tech. Retired from Law enforcement in 2008 after 25+ yrs.
chuckster57 is offline   Reply With Quote
Old 04-23-2021, 01:27 PM   #11
Trouble
Junior Member
 
Join Date: Apr 2021
Location: Pinson
Posts: 14
Nope black still lights up, I moved the blue fresh water over to what was colored for blk water, but then I noticed with no wires connected it still has a light
Trouble is offline   Reply With Quote
Old 04-26-2021, 02:10 PM   #12
Trouble
Junior Member
 
Join Date: Apr 2021
Location: Pinson
Posts: 14
Convenience Center lights

I have another thread on this in the light trailers,
new to the forum so I thought I would drop this in here to look for an answer.



2019 Springdale 1800BH

So this only thing that I have found not working is the lights for the freshwater and grey water levels. Has anyone had this issue? I have not found the pinout for the connections on the circuit board, all connections seem good and i have tested the continuity to the first crimp from the circuit board. just wondering if this is a board issue or a sensor in the tanks??
Trouble is offline   Reply With Quote
Old 04-27-2021, 04:07 AM   #13
Pull Toy
Senior Member
 
Pull Toy's Avatar
 
Join Date: Mar 2015
Location: Southeastern Connectiut
Posts: 1,203
Welcome to the forum.

I wouldn’t get too excited about the tank level gauges. They are notoriously inaccurate, and useless in the real world.

With some time and experience you will be able to have a good idea of your status.

Good luck,
Pull Toy is offline   Reply With Quote
Old 04-27-2021, 08:01 AM   #14
travelin texans
Senior Member
 
travelin texans's Avatar
 
Join Date: Nov 2017
Location: Picacho Peak Rv Resort
Posts: 4,575
Quote:
Originally Posted by Trouble View Post
I have another thread on this in the light trailers,
new to the forum so I thought I would drop this in here to look for an answer.



2019 Springdale 1800BH

So this only thing that I have found not working is the lights for the freshwater and grey water levels. Has anyone had this issue? I have not found the pinout for the connections on the circuit board, all connections seem good and i have tested the continuity to the first crimp from the circuit board. just wondering if this is a board issue or a sensor in the tanks??
If by chance you do get them to light up, that's about all it will tell you is that the lights are on.
__________________
Danny & Linda
Former '13 Redwood FB owner
Currently rvless!
travelin texans is offline   Reply With Quote
Old 04-27-2021, 08:22 AM   #15
travelin texans
Senior Member
 
travelin texans's Avatar
 
Join Date: Nov 2017
Location: Picacho Peak Rv Resort
Posts: 4,575
Quote:
Originally Posted by Trouble View Post
I have another thread on this in the light trailers,
new to the forum so I thought I would drop this in here to look for an answer.



2019 Springdale 1800BH

So this only thing that I have found not working is the lights for the freshwater and grey water levels. Has anyone had this issue? I have not found the pinout for the connections on the circuit board, all connections seem good and i have tested the continuity to the first crimp from the circuit board. just wondering if this is a board issue or a sensor in the tanks??
If by chance you do get them to light up, that's about all it will tell you is that the lights are on.
__________________

__________________
Danny & Linda
Former '13 Redwood FB owner
Currently rvless!
travelin texans is offline   Reply With Quote
Reply

Tags
light, lights

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV® is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 02:43 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×