PDA

View Full Version : Control panel issues, top row of lights and switches inoperable


fstmvrerik
02-07-2021, 08:43 PM
I have a 2021 Outback 340BH, getting it ready for a trip and I added water to the storage tank, and turned on the water pump to prime the system. When I did the 12v 10 amp fuse blew and now the top row of the control panel have become inoperable. Not working are the sewage and fresh water indicator lights and operating switches, the indicator lights on the toggle switches on the water pump, electric water heater, and gas operation of the water heater. The unit had been fully winterized, and the internal temp of the camper has been heated and kept above freezing all the time, and was at 65 when this process started. I have not replaced the 10amp fuse yet.
Before I replace the fuse should I be aware of anything I need to do before I start to trouble shoot this issue, by pulling other fuses or killing any systems as to not cause any further damage.
Just FYI it is currently 11 degrees right now, I am assuming the water pump had some residual water in it and was not able to run and caused the fuse to blow. I have opened up the water pump area and have direct heat in there and will try to replace the fuse after a night of heating directly ajacent to the water system.
Any thing else I need to do?
Thanks.

chuckster57
02-08-2021, 05:50 AM
Welcome to the forum :wlcm:

I would replace the fuse and try again. If it blows right away then post back, where is the blown fuse located?