PDA

View Full Version : Water Heater


JohnnyP
09-03-2020, 07:37 AM
My water heater fires and works great on LP but does not like to work on elec. The breaker is not tripped and the anode looks really good. 1st time on it got warm but then nothing. Any suggestions?

wiredgeorge
09-03-2020, 08:06 AM
My water heater fires and works great on LP but does not like to work on elec. The breaker is not tripped and the anode looks really good. 1st time on it got warm but then nothing. Any suggestions?


JohnnyP, You have to guess that there are several types of water heaters in Keystone campers. List your year, make and model as well as the same info for your tow vehicle in your signature which can be added by clicking the UserCP button on top/left of each page. Then open your outside water heater door and look around the edge for the manufacturer's label. Who made the thing and what model would really help answer your question. I know Suburban but not Atwood... just saying.

levic900rr
09-04-2020, 05:56 AM
I had some funky water heater issues early this season. I traced it back to a loose crimped connector on the panel. Just grab some needle nose and lightly pinch each connection to make sure they're tight.

Schbobby
09-05-2020, 04:28 AM
Also at Waterheater there is an electrical reset on the heater itself. See if the reset has popped by pushing these in!

travelin texans
09-05-2020, 08:54 AM
If it has an anode rod it's a Suburban heater. BTW that rod has nothing to do with the operation of the water heater, but should be checked at least annually to protect the tank.
The issue could be that someone has turned it to electric with no water in the tank & burnt up the element.
If the reset doesn't work remove the black cover & check that the thermostat wires haven't been shorted against the tank, had this on mine a few years ago.