PDA

View Full Version : 2014 Sprinter 311BHS Slide Issue


krogers385
08-31-2020, 05:42 AM
Good morning all, when leaving a campsite last week I pulled the rear slide in the night before we left but when I went to pull the main slide in the next morning I got no response at all. Also, the rear slide had no response even though it worked fine the night before.

Nothing wrong in the fuse panel in the rear and am trying to find if there are inline fuses somewhere. I could not locate any fuses other than the fuse panel (which had nothing labeled for the slides). I am confident there are fuses some where I have not located.

Would appreciate any ideas on the issue and solutions.

flybouy
08-31-2020, 07:57 AM
There should be 30amp or perhaps other Amp rated auto resetting breakers near the battery. As your trailer is 6 yrs old they may be corroded and have failed. Typically on a travel trailer they are screwed onto the A frame. Follow the positive cable from the battery post to find them.

travelin texans
08-31-2020, 08:24 AM
Check your battery/batteries, anything less than 12+ volts the slides won't operate.
If the batteries are the originals then 6 years is time for replacements, typically 5 is about the normal lifespan of rv batteries.

krogers385
08-31-2020, 12:23 PM
Thanks so much for the help. I will check those terminals. One thing I failed to mention is the awning still worked, the slides were the only thing I could find impacted and they have individual switches on the control panel. I will check your suggestions and let you know the outcome.