PDA

View Full Version : AC stops running


Schbobby
07-03-2020, 03:12 AM
I have a 2019 Cougar 33MLS with in-control and a domestic AC. When I start the AC it works great cools down the unit fully. Once it gets cool the AC and fan goes off and doesnít start back up. After it stops I can start the fan manually to keep air moving and after it gets warmer restart the AC again. I really donít like being the AC controller! This should work on its own!

Northofu1
07-03-2020, 03:47 AM
Does the in command system allow users to control the deadband? That is your on off /heating cooling control. You might want to narrow that band if so.

skids
07-03-2020, 03:50 AM
Thermostat

mmoff46
07-03-2020, 05:53 AM
My 3160rl was doing the same thing and I called Dometic and they said the thermostat was bad and sent me a new one. Works great now.

Lee
07-03-2020, 06:03 AM
Hum,.... another thing to consider.... is the Evap Coil freezing up?

flybouy
07-03-2020, 06:18 AM
Does the in command system allow users to control the deadband? That is your on of /heating cooling control. You might want to narrow that band if so.

The "dead band" is called a temperature differential.

JRTJH
07-03-2020, 06:29 AM
Dometic has had some significant issues with their thermostat/air conditioner interface. The Thermostat simply doesn't always perform as expected. Contact Dometic and discuss the problems, chances are that they'll send you a replacement thermostat and that will solve your problems...

If you take the trailer to a dealership service department, expect it to not be covered by warranty and after sitting several weeks, they won't be able to duplicate the problem, call you to come get the trailer, charge you a $100-200 diagnostic fee, and you'll be where you are right now.... Upon return to the dealership, hopefully a different tech will find the thermostat issue, replace it and only charge you around $300 for diagnostic fees and the replacement thermostat, but probably not the same color as the old one.

Just call Dometic and "do it yourself"

A hint: When you pull the thermostat off the wall, take a photo of the wires so you'll KNOW which wire goes to which connector. All you'll need is a #2 Roberts screwdriver and either a #1 Phillips or a small common (flat blade) screwdriver.

MarkEHansen
07-05-2020, 07:14 AM
The OP mentioned iN-Command, so likely doesn't have a separate thermostat.

Schbobby
07-06-2020, 02:42 AM
Yes it is the In-Command system, did find my software is about 3 years old, got home have a computer and will try the USB update to see if this gets fixed. If I control manually it works so will try update. Is not freezing up and gets worst when close to set temperature vs. big differential.

copperhand
07-06-2020, 04:18 AM
I was having similar issues and I did a full software update on my Incommand and it seems to have fixed it.....John

Schbobby
08-10-2020, 03:11 AM
After updating the In-Command to the latest software the AC works as expected and runs right!

skids
08-10-2020, 04:04 PM
Nice! You have to love a plan when it comes together.

DroughtBuster
09-23-2020, 11:32 AM
To update the software, did you first download it onto a thumb drive and plug that into the USB port on the In Commend panel?

Schbobby
09-23-2020, 12:09 PM
Yes I downloaded onto a thumb drive then brought to USB port on the IN Command panel. Fixed all!

Pharphr
09-23-2020, 09:25 PM
Mine did this also. I had already upgraded to the latest software. The next time I took the trailer out, it seemed to have healed itself and worked fine. I wasn't too happy with Dometic. I was on hold for over two hours, only to have them hang up on me when the tech went to ask someone else. InCommand at least answered the phone and talked to me, but they really weren't much help either.

I guess I'll just have to keep an eye on it.