Go Back   Keystone RV Forums > Keystone Tech Forums > Repairs & Maintenance
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 03-14-2013, 04:17 PM   #11
Chum T
Junior Member
 
Chum T's Avatar
 
Join Date: Nov 2012
Location: LA PORTE TX
Posts: 7
Andrew010,
On my Rv, a 2012 Cougar it's located in the front facing cargo compartment upper right side above the battery box. Just follow the instructions in above reply. I had to reprogram mind because all the controls were wrong. Take you a pen & paper with so that you can write down which each location controls. None of my wires were labeled so I had to redo the programming a couple times to get it right. Hope this helps & best of luck.

ChumT
__________________

Chum T is offline   Reply With Quote
Old 03-22-2013, 03:45 PM   #12
Andrew010
Junior Member
 
Join Date: Feb 2013
Location: Altoona, Ia
Posts: 15
Found the reset button and pressed it several times with no luck in fixing the problem.

Must be a faulty remote??
__________________

Andrew010 is offline   Reply With Quote
Old 03-24-2013, 06:23 PM   #13
Chum T
Junior Member
 
Chum T's Avatar
 
Join Date: Nov 2012
Location: LA PORTE TX
Posts: 7
Follow the link in post #9 from Steve. Save or download it so you can take it to the RV a follow the steps. Read it couple times & follow the steps one by one. There are several buttons you must push in sequence to make it all work.
Chum T is offline   Reply With Quote
Old 03-24-2013, 06:32 PM   #14
Andrew010
Junior Member
 
Join Date: Feb 2013
Location: Altoona, Ia
Posts: 15
Followed the directions to the letter. Repeated several times with no changes.
Andrew010 is offline   Reply With Quote
Old 03-25-2013, 04:57 PM   #15
Chum T
Junior Member
 
Chum T's Avatar
 
Join Date: Nov 2012
Location: LA PORTE TX
Posts: 7
Looking like you might have a warranty claim with this one. Sorry for your problem's with it. Hope your dealer can turn it around for you in little down time.
Chum T is offline   Reply With Quote
Old 03-25-2013, 07:10 PM   #16
Andrew010
Junior Member
 
Join Date: Feb 2013
Location: Altoona, Ia
Posts: 15
Purchasing dealer pretty much said tough cookie. They don't seem interested in trying to fix it.

They're answer was - Everything worked when it left, you must have done something to cause the problem.

There's another Keystone dealer (doesn't sell Cougar though) close by and I'm going to see if they will work with me to get this fixed under warranty. I would hope this would be under warranty at least. Not sure if a dealer that doesn't sell Cougar would be able to work on a Cougar or not. It's still a keystone product but not sure that matters.

I haven't had much luck with the purchasing dealer from the point I signed the paperwork so I'm not surprised at the lack of help from them. So much for service after the sale huh. Won't be doing any business with them in the future.
Andrew010 is offline   Reply With Quote
Old 03-26-2013, 05:29 AM   #17
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 9,915
Quote:
Originally Posted by Andrew010 View Post
Purchasing dealer pretty much said tough cookie. They don't seem interested in trying to fix it.

They're answer was - Everything worked when it left, you must have done something to cause the problem.

I haven't had much luck with the purchasing dealer from the point I signed the paperwork so I'm not surprised at the lack of help from them. So much for service after the sale huh. Won't be doing any business with them in the future.
Contact Keystone Customer Service. Ask them to recommend a dealer that will service your RV under warranty. Keystone needs to know this dealership is not working with you to resolve warranty problems. As the selling dealership, they have a responsibility to honor your warranty and to work with you to make sure you're satisfied. If they'er not doing this, Keystone needs to know. Also, to help other members avoid the problems you're facing, if you want to identify the dealership, feel free to post the name and location here. If nothing else, it may help others avoid the same problems "after signing on the dotted line"
__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Old 03-26-2013, 06:27 PM   #18
Andrew010
Junior Member
 
Join Date: Feb 2013
Location: Altoona, Ia
Posts: 15
I'm rather not name names at this point.

I did get my problem fixed though. I contacted another dealer that was fairy close and was able to get the remote switched out under warranty. I did have to program the remote myself but it wasn't hard to do. Very simple and only took a few mins and voila, everything works as it should now.


Hopefully no new problems arise on our first trip out!


Thanks again for everyone's input.
Andrew010 is offline   Reply With Quote
Old 03-27-2013, 11:07 PM   #19
Chum T
Junior Member
 
Chum T's Avatar
 
Join Date: Nov 2012
Location: LA PORTE TX
Posts: 7
Good to hear it's fixed & hats off to the nonselling dealer for taking care of you! Gives me a peace of mind that the priority network that we got with the RV just might pay off one day. Happy camping!
__________________

Chum T is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -8. The time now is 04:32 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
This forum is owned and operated by Social Knowledge, LLC. It is not authorized or endorsed by the Keystone RV Company and is not affiliated with the Keystone RV Company or its related companies in any way. Keystone RV® is a registered trademark of the Keystone RV Company.