Go Back   Keystone RV Forums > Keystone Tech Forums > Keystone Questions
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 10-15-2011, 12:03 PM   #1
atanchor
Junior Member
 
Join Date: Sep 2011
Location: Virginia
Posts: 4
Unhappy Freeze Guard TM winterizing system

I have this on my Montana High Country 343RL. I THOUGHT it would enable me to pump antifreexe from the jug (or bucket) through the RV water system using the water pump. Pump won't pick up suction. Am I missing something here?
__________________

atanchor is offline   Reply With Quote
Old 10-15-2011, 12:22 PM   #2
SteveC7010
Senior Member
 
SteveC7010's Avatar
 
Join Date: Sep 2011
Location: Northville NY in the Adirondacks
Posts: 1,952
If that is the system with the valve that has to be flipped and the suction hose screwed on in place of a cap and then the hose stuck down into a jug of pink stuff, then it should just work.

Make sure the hose is all the way to the bottom of the jug and there are no kinks or other blockage.

It may take a few seconds for the stuff to begin to flow, but it should just work.

One other question, did you install it yourself or did the dealer?
__________________

__________________

'11 Cougar 326MKS loaded with mods
'12 Ford F250 SuperCab 6.7 PowerStroke Diesel
Amateur Radio: KD2IAT (146.520) GMRS: WQPG808 (462.675 TPL 141.3)
SteveC7010 is offline   Reply With Quote
Old 10-15-2011, 06:46 PM   #3
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 9,931
I had the freezeguard system that I installed on my trailer. Initially, it was a PITA to get it to start drawing from the antifreeze container, but once you got it flowing, as long as you didn't let it draw air, you could change to a second gallon jug without problems.

I finally got tired of the hassle, removed the freezeguard system and built a separate siphon hose using a fitting like the one that connects the fresh water tank to the pump. Now I just remove the connection fitting from the fresh water tank (at the pump) and install the siphon hose fitting. Since then, no problems getting the pump to flow.
__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Old 10-16-2011, 09:32 PM   #4
gepaine
Senior Member
 
Join Date: May 2011
Location: Carnation, WA
Posts: 190
Put Antifreeze in Fresh Water Tank

I just blow out the system, drain the fresh water tank, and put two gallons of antifreeze in the fresh water tank, and the water pump picks it up easily. No need to install a winterizing kit on the water pump. No need to juggle gallon jugs of sticky antifreeze inside the trailer.
__________________

2011 Keystone Cougar 24RKS
2007 Cadillac Escalade
Prodigy P2 Brake Controller
Past Trailer:
Forest River R-POD RP-175
Past Tow Vehicle:
2008 Toyota Sienna
gepaine is offline   Reply With Quote
Old 01-18-2012, 01:32 PM   #5
atanchor
Junior Member
 
Join Date: Sep 2011
Location: Virginia
Posts: 4
thanks for the help

Quote:
Originally Posted by atanchor View Post
I have this on my Montana High Country 343RL. I THOUGHT it would enable me to pump antifreexe from the jug (or bucket) through the RV water system using the water pump. Pump won't pick up suction. Am I missing something here?
Well, I finally poured antifreeze in the suction hose to prime the pump and it worked just fine. It just took a while.
atanchor is offline   Reply With Quote
Old 10-12-2012, 03:08 PM   #6
Minnjoe
Junior Member
 
Join Date: Oct 2012
Location: Minnesota
Posts: 3
I have the same problem as atanchor except my unit is a 2012 I purchased this spring. I tried priming the pump and that did not work. I have taken the connection off that you would connect a short hose to to pump antifreeze thru the system and noticed it has a spring load valve in side of it? Blowing on it I can hear it operate however I cannot feel any air going through it. any idea why this wouldn't be just a normal hose connection?? This is my 9th RV in 22 years and in Minnesota I want to be able to winterized on the move and not use any air.
Minnjoe is offline   Reply With Quote
Old 10-12-2012, 04:10 PM   #7
hankpage
Site Team
 
hankpage's Avatar
 
Join Date: Jun 2009
Location: Jersey Shore - Nokomis, FL
Posts: 4,494
Quote:
Originally Posted by Minnjoe View Post
I have the same problem as atanchor except my unit is a 2012 I purchased this spring. I tried priming the pump and that did not work. I have taken the connection off that you would connect a short hose to to pump antifreeze thru the system and noticed it has a spring load valve in side of it? Blowing on it I can hear it operate however I cannot feel any air going through it. any idea why this wouldn't be just a normal hose connection?? This is my 9th RV in 22 years and in Minnesota I want to be able to winterized on the move and not use any air.
Sounds to me as if you are looking at the city water inlet .... that has a checkvalve in it. Winterizing inlet may also have the same setup but you don't say what make and model trailer you have. More info needed, Hank
__________________
Hank & Lynn
2007 Cougar 290RKS, E-Z Flex, 16" XPS RIBs
2004.5 Dodge 2500 QC, LB, 5.9HO, WestTach gauges, Ride-Rite
'07 Cougar Mods
hankpage is offline   Reply With Quote
Old 10-12-2012, 04:23 PM   #8
Minnjoe
Junior Member
 
Join Date: Oct 2012
Location: Minnesota
Posts: 3
Sory, 343RL just like atanchor your right it has a check value just Couldn't think what it was called. I took the side wall of the back side so I know what they labeled as the freeze guard inlet was correct since it went to the three way valve that is marked as the winterize on / off valve. I have not checked the three way valve yet to see if it is working

Joe
Minnjoe is offline   Reply With Quote
Old 10-13-2012, 04:38 AM   #9
mr.windows1
Member
 
Join Date: Feb 2012
Location: Champlin Mn.
Posts: 71
I just had the same problem there is a thread in Fifth wheels under winterizing and you can read my final post it is bizarre but in the end what the dealer told me did work but it still don't make any sense.
__________________
2012 Keystone Montana 3750FL
6 Point leveling
32 in.Outside LCD
2011 Ford F-350 Lariat SRW
6.7L Powerstroke Diesel
Reese Pro Series Slider
mr.windows1 is offline   Reply With Quote
Old 12-28-2012, 06:48 PM   #10
gduff
Junior Member
 
Join Date: Nov 2012
Location: Milton, VT
Posts: 7
I used ours with the short hose. Picked it up from the jug right away without any problems.
__________________

__________________
2013 Montana High Country 318RE
2008 Chevy 2500HD EC D/A
52 gal aux fuel tank
Firestone Air Bags
Pullrite Superglide
gduff is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -8. The time now is 10:45 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
This forum is owned and operated by Social Knowledge, LLC. It is not authorized or endorsed by the Keystone RV Company and is not affiliated with the Keystone RV Company or its related companies in any way. Keystone RV® is a registered trademark of the Keystone RV Company.