Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Fifth Wheels
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 05-22-2018, 06:36 PM   #1
Gbjb584
Junior Member
 
Join Date: May 2018
Location: URBANA
Posts: 3
2018 cougar power troubleshoot

I have electricity to RV but can't get slides and leveling system to work.
__________________

Gbjb584 is offline   Reply With Quote
Old 05-22-2018, 06:45 PM   #2
66joej
Senior Member
 
66joej's Avatar
 
Join Date: Feb 2014
Location: radium hot springs bc
Posts: 1,398
Do you have a fully charged battery in the Trailer? I believe both those items run off the house battery.
__________________

__________________
2013 Cougar 24RKSWE
2015 f150 Screw 5.0 LT tires 2040# payload
Equal-i-zer 10K hitch
66joej is offline   Reply With Quote
Old 05-22-2018, 09:29 PM   #3
bobbecky
Senior Member
 
bobbecky's Avatar
 
Join Date: Jul 2013
Location: Box Elder
Posts: 1,137
It’s very possible that you have a failed thermal breaker that feeds the hydraulic pump. They usually have a red plastic cover over the terminals, and the one that has the wire going to the hydraulic pump would be the one to check. This is all assuming you have a hydraulic system. If it is all electric, there might be a common electric feed that has failed, possibly also a thermal circuit breaker.
bobbecky is online now   Reply With Quote
Old 05-23-2018, 03:24 AM   #4
Gbjb584
Junior Member
 
Join Date: May 2018
Location: URBANA
Posts: 3
Quote:
Originally Posted by 66joej View Post
Do you have a fully charged battery in the Trailer? I believe both those items run off the house battery.
Will have to check. Kind of baffled as this is a brand new camper and wouldn't think the battery would be bad already. Thanks for the input.
Gbjb584 is offline   Reply With Quote
Old 05-23-2018, 03:26 AM   #5
Gbjb584
Junior Member
 
Join Date: May 2018
Location: URBANA
Posts: 3
Would this wire be found near the battery? Am I checking for loose connections? Thanks
Gbjb584 is offline   Reply With Quote
Old 05-25-2018, 05:29 AM   #6
ctbruce
Site Team
 
ctbruce's Avatar
 
Join Date: Dec 2015
Location: Kansas City
Posts: 2,887
Not looking for a bad battery. Looking for a fully charged battery.
__________________

Chip Bruce, RPh
Kansas City, MO
2016 Impact 312
2017 Silverado 3500HD SRW
ctbruce is offline   Reply With Quote
Old 05-25-2018, 06:17 PM   #7
Branden_Rodgers
Junior Member
 
Join Date: May 2018
Posts: 7
Make sure your battery disconnect it in the On position. If its not your battery will not feed the 12v system. Also it will not charge your battery.... ask me how I know!
Branden_Rodgers is offline   Reply With Quote
Old 05-28-2018, 06:20 AM   #8
jlb27537
Member
 
jlb27537's Avatar
 
Join Date: Jan 2013
Posts: 55
On my Montana, both the slides and 6pt hyd system will work with the battery switch in the off position. The pump is fed thru 80a breakers.

Some trailers were built with 40a breakers and if the fluid is cold, would trip the breakers. The battery switch disconnects the house battery from the house loads and converter. The hyd system is always connected to the battery.
__________________

jlb27537 is offline   Reply With Quote
Reply

Tags
cougar, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 07:19 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.