Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Toy Haulers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 06-29-2017, 02:39 PM   #1
Kelsc
Junior Member
 
Join Date: Jun 2017
Location: Gulfport
Posts: 12
Onan 5500 generator starts, no power

We have no power to the rv appliances and ac. Only items running off the battery. The generator is running but no power. Checked generator breaker, main rv breakers, and converter has a green light in the box. There is no flashing red light for a code on the generator. Any help would be great! In Michigan with no hook ups. AC would be nice!! Thanks all in advance.
__________________

Kelsc is offline   Reply With Quote
Old 06-29-2017, 03:23 PM   #2
Pull Toy
Senior Member
 
Pull Toy's Avatar
 
Join Date: Mar 2015
Location: Southeastern Connectiut
Posts: 921
Have you checked for voltage right at the generator output, and double checked the breakers on the genny and the camper? Try a volt meter, or plugging a drop light at the output leads, or outlet on the genny.

If you are getting power at the convertor, it's not the genny. That may be your issue. Try throwing all 110 breakers off, then back on a few times in case they need to be exercised.

Let us know how you make out.

Good Luck,
__________________

__________________

Pull Toy

Steve & Jan, Ava & Emma (Mini Schnauzers):
2016 F350 Lariat 4X4 Powerstroke CC/SB "PULLTOY V"
2013 Alpine 3535RE "MAGIC CARPET III"
Proud Navy Vet!
Pull Toy is offline   Reply With Quote
Old 06-29-2017, 04:03 PM   #3
PARAPTOR
Site Team
 
PARAPTOR's Avatar
 
Join Date: Jan 2014
Location: Western PA
Posts: 2,634
Not sure how familiar you are with electricity but if it were me I would pull the cover off the transfer switch everything right there. Check generator output as well as the functioning of the transfer switch and feed to the main power distribution panel.

As noted and in previous posts there have been cases where the breakers on the generator have tripped on startup. Can do a search on previous posts
__________________
2013 RAPTOR 300MP w/Rear Patio Deck NO Folding Side Ladder
2013 Silverado 3500HD LTZ CC LB 4X4 DRW
Duramax 6.6L Turbo Diesel; Allison Trans
Reese 20K; Carlisle Radial Trail RH/HD; TPMS (12 Tires)

Veteran


PSU (GO LIONS)
PARAPTOR is offline   Reply With Quote
Old 06-29-2017, 07:30 PM   #4
Kelsc
Junior Member
 
Join Date: Jun 2017
Location: Gulfport
Posts: 12
We don't have a multimeter. We hooked it up to a different generator from our shore power cable and everything worked. It would transfer over to our onan but still no power. No fuse or switch at box in basement, just a green light in there by the wires. SOOO We got it working.... from hitting that box with a screwdriver. Turns out the relay was stuck! Thanks everyone!
Kelsc is offline   Reply With Quote
Old 06-30-2017, 06:22 AM   #5
notanlines
Senior Member
 
notanlines's Avatar
 
Join Date: Oct 2014
Location: Memphis, TN
Posts: 2,808
Most of us on this forum are familiar with the old "hit it with a screwdriver" trick. I never tried it on any of the children when they were little, but in hindsight.....
And thanks for letting us in on the results.
__________________
Jim in Memphis
Wife of 46 years is Brenda
2014 F-350 6.7 Powerstroke
2017 Mobile Suites
20K Reese slider
2001 Road king w/matching Harley sidecar
notanlines is offline   Reply With Quote
Old 06-30-2017, 07:28 AM   #6
PARAPTOR
Site Team
 
PARAPTOR's Avatar
 
Join Date: Jan 2014
Location: Western PA
Posts: 2,634
Sort of glad you found a remedy , not excited how you may have fixed it
Military repair

I would monitor the operation of that transfer switch, low contact pressure can result in possible arcing which will corrode those contacts. On mine when that transfer switch changes state you can definitely can hear it slam shut I still would take that cover off the transfer switch and examine the internals
__________________

__________________
2013 RAPTOR 300MP w/Rear Patio Deck NO Folding Side Ladder
2013 Silverado 3500HD LTZ CC LB 4X4 DRW
Duramax 6.6L Turbo Diesel; Allison Trans
Reese 20K; Carlisle Radial Trail RH/HD; TPMS (12 Tires)

Veteran


PSU (GO LIONS)
PARAPTOR is offline   Reply With Quote
Reply

Tags
generator, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 05:46 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.