Go Back   Keystone RV Forums > Keystone Tech Forums > Keystone Questions
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 12-13-2017, 03:46 PM   #1
piccolo
Junior Member
 
Join Date: Dec 2017
Location: lexington
Posts: 3
how to prime water pump

I have a 2015 326rl and am having trouble getting the pump to pull water out of fresh water tank. I have the fresh/city water inlet and have put around 15 gallons in FW tank but when I open the hot or cold in sinks or shower no water is being pumped out. I hear the pump coming on and wait for a few minutes but no water.. Any suggestions???
__________________

piccolo is offline   Reply With Quote
Old 12-13-2017, 04:29 PM   #2
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 11,950
First, does the system operate properly on city water? If not, it's not the water pump. If it does operate properly, then I'd suspect you have a valve in the convenience center improperly positioned. Either the winterize valve (draws antifreeze or draws water from the Fresh Water Tank) or another valve, possibly the tank fill valve ??? If your trailer operates properly on city water, I'd suspect the winterize valve.
__________________

__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Old 12-14-2017, 10:49 AM   #3
Lee
Senior Member
 
Join Date: Feb 2013
Location: Lacey, WA
Posts: 185
Hi,

I had the exact same problem with mine last Spring.

On my rig, I had cut the input line to the pump from the FWT and installed a "T". I then installed a valve and a short piece of tubing onto the "T". When I winterize I open this valve and put the end on the tube into a gallon jug of pink antifreeze. When I turn on the pump and open a faucet antifreeze gets sucked into the pump and sent out to the open faucet.

When I had my No Prime problem, I opened the winterize valve and poured a little bit of water into the end of the hose which primes the pump. Then closed the valve and "Wallah" pump operated normally.
__________________
Lee

1970 F250 Highboy 4x4
2013 Cougar 21RBSWE
Lee is offline   Reply With Quote
Old 12-22-2017, 09:58 AM   #4
Harleydodge
Senior Member
 
Join Date: Jun 2017
Location: Kingston
Posts: 132
Quote:
Originally Posted by piccolo View Post
I have a 2015 326rl and am having trouble getting the pump to pull water out of fresh water tank. I have the fresh/city water inlet and have put around 15 gallons in FW tank but when I open the hot or cold in sinks or shower no water is being pumped out. I hear the pump coming on and wait for a few minutes but no water.. Any suggestions???
So you hear the pump come on exactly when you open a faucet, and it shuts off when you close it? or is the pump running all the time when you turn it on at the switch?
I'm trying to make sense of it, because the pump itself it activated by a pressure drop in the line.
__________________
2013 Raptor 310ts Toy Hauler
2017 Dodge Ram 6.7l CTD DRW Laramie Longhorn
Harleydodge is offline   Reply With Quote
Old 12-22-2017, 02:45 PM   #5
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 11,950
The OP posted this thread at 7:46PM on 12-13. He signed off the forum at 07:51 PM that evening and has not yet signed back onto the forum. It appears he has not seen any of the responses to his initial post since all of them are after his "7:51 departure"...
__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Old 12-22-2017, 03:01 PM   #6
Harleydodge
Senior Member
 
Join Date: Jun 2017
Location: Kingston
Posts: 132
Quote:
Originally Posted by JRTJH View Post
The OP posted this thread at 7:46PM on 12-13. He signed off the forum at 07:51 PM that evening and has not yet signed back onto the forum. It appears he has not seen any of the responses to his initial post since all of them are after his "7:51 departure"...
Another "hit and run"
Oh well...hope he figures it out.
__________________
2013 Raptor 310ts Toy Hauler
2017 Dodge Ram 6.7l CTD DRW Laramie Longhorn
Harleydodge is offline   Reply With Quote
Old 12-22-2017, 04:19 PM   #7
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 11,950
My guess is he did. Otherwise, he'd have likely been back to look for help.
__________________

__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Reply

Tags
water, water pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3

All times are GMT -8. The time now is 04:05 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
This forum is owned and operated by Social Knowledge, LLC. It is not authorized or endorsed by the Keystone RV Company and is not affiliated with the Keystone RV Company or its related companies in any way. Keystone RV® is a registered trademark of the Keystone RV Company.