Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Toy Haulers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-12-2018, 08:40 AM   #1
Drennen7
Junior Member
 
Join Date: Aug 2016
Location: Thornton, CO
Posts: 18
Inverter Problems

Howdy,
Battling inverter issues on my Fuzion Chrome 414. My unit has the residential fridge so we've got the red power inverter mounted in the front storage compartment from the factory (sorry I don't have the make/model).
When plugged in to shore power I get a single green light and it appears to be passing power through to the fridge outlet. But, no display, no fans kicking on, etc. like normal. I get the same result when the generator is running. However, the second we unplug or the turn the generator off, the inverter is dead and the fridge goes dark.
Thinking it's one of about 3 possibilities but hoping someone has encountered this before?
1 - fuse on the inverter is bad (will try this first)
2 - Internal batteries on the inverter are bad, but feels like I should still get a display when running on shore or generator power?
3 - inverter is toast after 18 months... That would be disappointing.

Any ideas?

Thanks in advance!

Randy
__________________

__________________

2016 Fuzion Chrome 414
2013 Ford F-350
Drennen7 is offline   Reply With Quote
Old 07-12-2018, 03:53 PM   #2
SC Dreamer
Senior Member
 
Join Date: May 2018
Location: Columbia
Posts: 125
Check your batteries and voltage from them to the inverter. If you have good voltage from batterries and even on shore power the display doesnt work, then the problem is with the inverter. Maybe there is a fuse in it? If no fuse, then i would reach out to manufacturer. Maybe they can fix it cheaper then replacing.
__________________

SC Dreamer is offline   Reply With Quote
Old 07-13-2018, 07:33 PM   #3
MattHelm21
Senior Member
 
MattHelm21's Avatar
 
Join Date: Nov 2016
Location: Sussex, NJ
Posts: 373
There is a switch in your battery compartment which needs to be turned on. I beleive it turns clockwise looking up from underneath. The behavior you are experiencing is by design when the switch is turned counterclockwise.
Attached Thumbnails
Click image for larger version

Name:	B427B308-2D94-47F2-987C-16A7D8B317CD.jpg
Views:	18
Size:	146.5 KB
ID:	17456  
__________________
2016 Fuzion 414 Chrome
2016 Ford F450 Super Duty King Ranch
MattHelm21 is offline   Reply With Quote
Old 07-13-2018, 08:17 PM   #4
Old Mustanger
Senior Member
 
Old Mustanger's Avatar
 
Join Date: May 2015
Location: Rockett, TX
Posts: 179
Your inverter sounds like the same one I have, could it simply be the on-off button on the inverter itself (located near the pass thru light)?
__________________
Jerry & Debbie
with Fur Babies Sasha & Sam
2018 Alpine 3401RS
2015 F250
Old Mustanger is offline   Reply With Quote
Old 07-15-2018, 10:10 AM   #5
Drennen7
Junior Member
 
Join Date: Aug 2016
Location: Thornton, CO
Posts: 18
Thank you both for the replies! I know the switch your referencing. I’ll investigate that as an option.
Thanks!
__________________

2016 Fuzion Chrome 414
2013 Ford F-350
Drennen7 is offline   Reply With Quote
Old 07-16-2018, 12:43 PM   #6
Drennen7
Junior Member
 
Join Date: Aug 2016
Location: Thornton, CO
Posts: 18
Thank you for saving my marriage. It was the kill switch in the battery compartment!
__________________

__________________

2016 Fuzion Chrome 414
2013 Ford F-350
Drennen7 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 04:56 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.