Go Back   Keystone RV Forums > Welcome to KeystoneForums.com! > New Member Check in!
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 10-12-2019, 11:32 AM   #1
Jwaldrich
Junior Member
 
Join Date: Oct 2019
Location: Orting
Posts: 1
New Member

Got a 2016 Cougar we bought new. Seems like there is always something wrong or broken. 😥
__________________

Jwaldrich is offline   Reply With Quote
Old 10-12-2019, 12:40 PM   #2
wiredgeorge
Senior Member
 
wiredgeorge's Avatar
 
Join Date: Nov 2017
Location: Mico
Posts: 1,009
Welcome. Sorry to hear you are having issues. This is the place to be to find fixes.
__________________

__________________
wiredgeorge Mico TX
2006 F350 CC 4WD 6.0L
2002 Keystone Cougar 278
2006 GL1800 Roadsmith Trike
wiredgeorge is offline   Reply With Quote
Old 10-12-2019, 01:58 PM   #3
travelin texans
Senior Member
 
travelin texans's Avatar
 
Join Date: Nov 2017
Location: Picacho Peak Rv Resort
Posts: 2,468
Quote:
Originally Posted by Jwaldrich View Post
Got a 2016 Cougar we bought new. Seems like there is always something wrong or broken. 😥
Sounds like a typical RV!
Consider there's an 8.0 earthquake going on inside/outside of it every time you haul it down these wonderful roadways it's not surprising.
__________________
Danny & Linda
Former '13 Redwood FB owner
Currently rvless!
travelin texans is offline   Reply With Quote
Reply

Tags
new member

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV® is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 10:40 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×