Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Fifth Wheels
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 05-09-2018, 02:50 AM   #1
BIG KAHUNA
Member
 
BIG KAHUNA's Avatar
 
Join Date: Jul 2017
Location: LACONIA
Posts: 38
Fan not working

For whatever reason the MAXXAIR fan in our 5th does not function. It has a lid motor as well as a fan motor and neither one functions. It was working correctly before closing up for Winter. This is a unit that has a 4 function remote and rain sensor. Does anyone know if it has an internal fuse/circuit breaker? I would find it odd it has its own fuse in the panel and everything else works, but to be honest I haven't checked fuses so that's my next step. It would be nice if Keystone labeled the fuses. Thoughts?
__________________

BIG KAHUNA is offline   Reply With Quote
Old 05-09-2018, 02:57 AM   #2
Pull Toy
Senior Member
 
Pull Toy's Avatar
 
Join Date: Mar 2015
Location: Southeastern Connectiut
Posts: 887
What comes to mind:

1. Batteries in remote?

2. Power to unit. The fact that neither motor works sounds like a fuse, or mouse damage to me.

Good Luck,
__________________

__________________

Pull Toy

Steve & Jan, Ava & Emma (Mini Schnauzers):
2016 F350 Lariat 4X4 Powerstroke CC/SB "PULLTOY V"
2013 Alpine 3535RE "MAGIC CARPET III"
Proud Navy Vet!
Pull Toy is offline   Reply With Quote
Old 05-09-2018, 03:30 AM   #3
BIG KAHUNA
Member
 
BIG KAHUNA's Avatar
 
Join Date: Jul 2017
Location: LACONIA
Posts: 38
Fan problem

So I just bought a fuse tester from Amazon that will arrive on Friday, but I'm also fearful about rodent damage.
BIG KAHUNA is offline   Reply With Quote
Old 05-09-2018, 03:52 AM   #4
Ddubya
Senior Member
 
Ddubya's Avatar
 
Join Date: Oct 2016
Location: Sherman
Posts: 246
There should be a fuse on the fan. Look on the opposite corner froom manual lid crank.
__________________
2017 Alpine 3401RS,Titan Disc,Morryde SRE 4000, 2016 Ram 3500HD Laramie SRW,LWB,4X4, Aisin transmission

Ddubya is offline   Reply With Quote
Old 05-09-2018, 04:46 AM   #5
JRTJH
Site Team
 
JRTJH's Avatar
 
Join Date: Mar 2011
Location: Gaylord
Posts: 12,885
If the fan was stored in the closed position, the lid may have "stuck" to the rubber gasket that seals the lid. You might simply have a situation where the lid motor can't open the lid and the fan motor won't turn on until the lid is open. Before "tearing into things" you might want to get on the roof and use your fingers to help the lid motor get the lid to start moving.

While this may not be your problem, it is something that "ought to be done" before disassembling the fan, looking for failures.
__________________
John



2015 F250 6.7l 4x4
2014 Cougar X Lite 27RKS
JRTJH is offline   Reply With Quote
Old 05-09-2018, 03:40 PM   #6
cpaulsen
Senior Member
 
cpaulsen's Avatar
 
Join Date: Apr 2009
Location: Oregon Coast
Posts: 253
There is a fuse on the unit itself.
cpaulsen is offline   Reply With Quote
Old 05-16-2018, 09:13 AM   #7
Cougar1957
Member
 
Cougar1957's Avatar
 
Join Date: Oct 2014
Location: Packerland
Posts: 49
I had a similar issue with mine right after picking it up. What worked for me was double-clicking the fan button...started right up. Its weird because I could find no documentation that this was even a feature or a troubleshooting step. I rarely have this issue, but when I do, the double-click works every time.
__________________

__________________
Jim & Kristie
2002 F-350 PSD, 4X4, Lariat, crew cab, long bed, SRW
2015 Cougar X-Lite High Country 28SGS 5'ver
Reese 16K & Tekonsha PrimusIQ digital controller
The K9 crew: Ginger the terrier, Yorkies - Heidi & Dora, & Buddy the Chihuahua
Cougar1957 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 10:05 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.