Go Back   Keystone RV Forums > Keystone Tech Forums > Keystone Questions
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 06-10-2019, 07:35 PM   #1
Gordon429
Junior Member
 
Join Date: Jun 2019
Location: Surprise
Posts: 5
Ac not blowing hard.

I have Fuzion 429 with 3 ac units. We noticed that the AC in the main room/living room is very uncomfortable and does not blow hard. Any tips and tricks? I know the master bed AC and main living area run on the same track. Has anyone blocked an air vent to try to forse more air out?
__________________

Gordon429 is offline   Reply With Quote
Old 06-11-2019, 04:14 AM   #2
curtthegreat
Junior Member
 
Join Date: Aug 2016
Location: Michigan
Posts: 29
Welcome to the forum Gordon. We have a 2016 Fuzion 420, with 3 A/C units. If you do a search on here you will see that others have had some success taking the cover off the units, inside the camper, and checking for anything obstructing the air flow. I did this and had some increase in air flow, but not enough to matter. I finally just eliminated the flow through the duct work and now have all 3 units dumping air straight down. The center unit, zone 1, is above the loft, I put a 20" fan up there only when it's very hot outside and it keeps the camper quite cool. Also, I generally have to cool all 3 zones, so I set the thermostat at our desired temp, for all 3 zones and put all 3 on auto and leave it. Turning the A/C's off at night and waiting until the camper heats back up before turning the units back on is the kiss of death.
__________________

__________________
2013 F350 CC King Ranch
2016 Fuzion 420
curtthegreat is offline   Reply With Quote
Old 06-11-2019, 05:09 AM   #3
Gordon429
Junior Member
 
Join Date: Jun 2019
Location: Surprise
Posts: 5
Great idea with the fan in the loft!!! I’m going to do the same thing! Thank you so much for your response!
Gordon429 is offline   Reply With Quote
Old 06-11-2019, 06:03 AM   #4
NH_Bulldog
Senior Member
 
NH_Bulldog's Avatar
 
Join Date: Apr 2019
Location: Henniker
Posts: 132
In my post here: http://www.keystoneforums.com/forums...ad.php?t=38150 you can see what might be part of your airflow issue.
__________________
Rob & Amy
2019 Passport 240BH SL
2015 Ford F150 3.5L Ecoboost SCrew 4x4 w/Max Tow Pkg
NH_Bulldog is offline   Reply With Quote
Old 06-12-2019, 04:26 AM   #5
jkohler70
Senior Member
 
jkohler70's Avatar
 
Join Date: Jun 2014
Location: Saint Louis, MO
Posts: 234
I found that my ducts had a lot of dead space at the end. I plugged up the extra duct and my airflow increased a lot.
__________________
2009 Kia Borrego EX V8
2014 Passport 2510RB
jkohler70 is offline   Reply With Quote
Old 06-12-2019, 05:26 AM   #6
Gordon429
Junior Member
 
Join Date: Jun 2019
Location: Surprise
Posts: 5
Thanks all. I am picking the 5th up tomorrow for a small weekend trip. I’ll pop the AC panel off and let you know what I find!
__________________

Gordon429 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 04:05 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.