Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-21-2018, 06:59 AM   #11
RickSprinter56
Junior Member
 
Join Date: Apr 2014
Location: Black Lake in Hammond
Posts: 2
Thanks to everyone who replied. Sorry I haven’t updated you. Dealer sent best tech 200 miles to troubleshoot and fix my electric problem. After 2 hours of testing every breaker, fuse, junction, continuity he popped the outlet cover right above the circuit breaker box. The wires back there fell right out. Apparantly, Keystone did a crappy job securing those wires and there must have been one that led to the other outlets along the slide out. He pushed the wires back in and all 3 outlets worked, yippee!!
__________________

RickSprinter56 is offline   Reply With Quote
Old 07-21-2018, 07:20 AM   #12
compeakw
Senior Member
 
compeakw's Avatar
 
Join Date: Feb 2017
Location: Potsdam
Posts: 144
Glad to hear you got it resolved. Thanks for the update.
__________________

__________________


2015 Bullet 220RBI
2016 Chevy Colorado crew cab V6 3.6 liter
compeakw is offline   Reply With Quote
Reply

Tags
keystone

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 05:59 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.