Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Travel Trailers
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 10-09-2019, 11:50 AM   #1
Joe Gagliardo
Junior Member
 
Join Date: Oct 2019
Location: San Antonio
Posts: 5
Light on front of trailer

New to site. The light on the front of the trailer above the hitch is not getting power. I tried the two switches inside the door on the cabinet. One turns on the exterior light next to the door, but the other one does nothing. Help?
__________________

Joe Gagliardo is offline   Reply With Quote
Old 10-09-2019, 12:20 PM   #2
Snoking
Senior Member
 
Snoking's Avatar
 
Join Date: Aug 2018
Location: Lake Stevens
Posts: 552
Might help to know year, make and model of your trailer. We have a 2019 Laredo with lights built into the front cap and the switch is in the front pass through storage next to the battery switch and landing gear/stabilizers switch. Chris
__________________

__________________
2019 Laredo 225MK for travel. Bighorn 3575el summer home in Washington, Park Model with Arizona Room for winters.
Snoking is online now   Reply With Quote
Old 10-09-2019, 12:28 PM   #3
Joe Gagliardo
Junior Member
 
Join Date: Oct 2019
Location: San Antonio
Posts: 5
2003 Explorer.
Joe Gagliardo is offline   Reply With Quote
Old 10-09-2019, 12:43 PM   #4
Snoking
Senior Member
 
Snoking's Avatar
 
Join Date: Aug 2018
Location: Lake Stevens
Posts: 552
Is this a word game? Need more info. Are you talk about a light mounted to the body of the trailer on the front wall/cap? Does it have a switch built into this light? A 2003 trailer could have a loose connection just about anywhere, blow fuse, bad switch, or bulb!


Chris
__________________
2019 Laredo 225MK for travel. Bighorn 3575el summer home in Washington, Park Model with Arizona Room for winters.
Snoking is online now   Reply With Quote
Old 10-09-2019, 02:39 PM   #5
wiredgeorge
Senior Member
 
wiredgeorge's Avatar
 
Join Date: Nov 2017
Location: Mico
Posts: 1,079
Joe just climbed aboard this looney wagon so some patience may be in order! He has a 2003 Keystone RV Explorer. I personally have never heard of this model so perhaps a picture of the light would be helpful as I doubt the specific model (might be helpful) or a long description of the light's location will work well.

JOE! Does your phone take pics? If so, take a pic, email to yourself and save to your desktop then click ATTACH FILES below the composition window and browse for your picture and attach it. That might make an answer more likely.
__________________
wiredgeorge Mico TX
2006 F350 CC 4WD 6.0L
2002 Keystone Cougar 278
2006 GL1800 Roadsmith Trike
wiredgeorge is offline   Reply With Quote
Old 10-10-2019, 04:13 PM   #6
Joe Gagliardo
Junior Member
 
Join Date: Oct 2019
Location: San Antonio
Posts: 5
Pic of light

I looked at fuses and the fixture I connected is new with a new bulb - but not getting power to the wires.
Attached Thumbnails
Click image for larger version

Name:	IMG_3062.jpg
Views:	71
Size:	76.9 KB
ID:	23992  
Joe Gagliardo is offline   Reply With Quote
Old 10-10-2019, 04:19 PM   #7
Joe Gagliardo
Junior Member
 
Join Date: Oct 2019
Location: San Antonio
Posts: 5
Close Up

This is a better close up pic.
Attached Thumbnails
Click image for larger version

Name:	IMG_3063.jpg
Views:	41
Size:	44.6 KB
ID:	23993  
Joe Gagliardo is offline   Reply With Quote
Old 10-10-2019, 04:57 PM   #8
flygrimm
Junior Member
 
Join Date: Jul 2019
Location: BETHLEHEM
Posts: 11
Joe

Is that one of the running lights or a utility light? If itís a running light it may be the last in line. I would check the wiring at the other lights. Maybe one of the wires supplying power to your dead light is loose resulting in your no power situation.

Stuart
flygrimm is offline   Reply With Quote
Old 10-10-2019, 05:05 PM   #9
Joe Gagliardo
Junior Member
 
Join Date: Oct 2019
Location: San Antonio
Posts: 5
Light

It is a utility light. All other lights (running, exterior, and interior) work.
Joe Gagliardo is offline   Reply With Quote
Old 10-10-2019, 05:14 PM   #10
flybouy
Site Team
 
Join Date: Oct 2011
Location: Joppa, MD
Posts: 1,976
Quote:
Originally Posted by Joe Gagliardo View Post
New to site. The light on the front of the trailer above the hitch is not getting power. I tried the two switches inside the door on the cabinet. One turns on the exterior light next to the door, but the other one does nothing. Help?
Did the light work in the past? The switches on the cabinet, have you pulled out the switch that you say "does nothing" to see if it has voltage going in and coming out?
__________________
Marshall
2012 Laredo 303 TG
2010 F250 LT Super Cab, long bed, 4X4, 6.4 Turbo Diesel
flybouy is offline   Reply With Quote
Old 10-10-2019, 06:04 PM   #11
wiredgeorge
Senior Member
 
wiredgeorge's Avatar
 
Join Date: Nov 2017
Location: Mico
Posts: 1,079
Hey neighbor! I have a similar lamp on my 5ver and it has a slide switch on the fixture. It is used for illuminating the front if you dig things out of the forward storage compartment. Since you don't have a front compartment, have you looked inside the pass through to see if you can see where the wires are going? Could there be a switch in the pass through? Generally the switches inside the door will turn on a "porch light" and on many campers there with be a fore and aft set of outside white lights.
__________________
wiredgeorge Mico TX
2006 F350 CC 4WD 6.0L
2002 Keystone Cougar 278
2006 GL1800 Roadsmith Trike
wiredgeorge is offline   Reply With Quote
Old 10-20-2019, 12:26 PM   #12
belljo54
Junior Member
 
Join Date: Jun 2018
Location: Pawtucket
Posts: 3
I have a 2018 Cougar 5th wheel. The utility light above my hitch only works via the little remote control that I otherwise find useless.
belljo54 is offline   Reply With Quote
Old 10-22-2019, 05:20 PM   #13
Nitehawk
Junior Member
 
Join Date: Jun 2018
Location: Deux Montagnes,Quebec
Posts: 26
If possible check continuity on the ground .should be easily to do since it is close to the frame
__________________

Nitehawk is offline   Reply With Quote
Reply

Tags
light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RVģ is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 05:13 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
×