Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Fifth Wheels
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 04-20-2018, 09:43 AM   #1
rshipyor
Junior Member
 
Join Date: Mar 2018
Location: Marquette
Posts: 15
Tv and micro have no power on 25 res

I am new to this forum and just picked up our new 25res half ton fifth wheel. Everything has power but the tv and micro. I check the circuit breakers and gfi and fuses. Does anyone have a idea what to try.
__________________

rshipyor is offline   Reply With Quote
Old 04-20-2018, 09:53 AM   #2
Ken / Claudia
Senior Member
 
Join Date: Nov 2012
Location: Gladstone,Ore
Posts: 2,159
Your not posting enough information, what power source are you using? Those items will not ever work without shore power or a generator running and plugged in. Is it hooked up to outside power? If so double check the breaker that it is plugged into. If all that is working, double check every breaker by turning them off and then back on. Looking that them is not enough.
__________________

__________________
2013 24RKSWE (27ft TT) Cougar 1/2 ton series
2002 Ford F350 4x4 CC 7.3 with aftermarket auto transmisson.
18ft 200hp jet boat.
Yellow Lab "Dacoda"
Retired Oregon State Police
Now a small town traffic cop
Ken / Claudia is offline   Reply With Quote
Old 04-20-2018, 09:53 AM   #3
sourdough
Senior Member
 
Join Date: Feb 2014
Location: W. Texas
Posts: 5,407
Welcome to the forum! Sorry it's under these circumstances.

Did they (y'all) not check the unit out at the dealer before you took off with it? Does it have a fireplace? Does it work? Have you plugged anything into the outlets to see if you have power? Whatever you are plugged into may not be providing 120 vac. Do you have a meter to check?
__________________
Danny & Susan wife of 50 years
2014 Ram 2500 6.4 4x4 CC
2014 Cougar High Country 319RLS
sourdough is offline   Reply With Quote
Old 04-20-2018, 11:35 AM   #4
rshipyor
Junior Member
 
Join Date: Mar 2018
Location: Marquette
Posts: 15
Turns out connection to shore power was bad fixed it and now all works.
Thank you for the kind words and information.
rshipyor is offline   Reply With Quote
Old 04-20-2018, 03:51 PM   #5
travelin texans
Senior Member
 
travelin texans's Avatar
 
Join Date: Nov 2017
Location: Picacho Peak Rv Resort
Posts: 1,066
Your next purchase should be a surge protector/EMS, portable or hardwired, for your rv to protect those electronics from bad connnections, yep they're pricey, but so is a microwave, fridge, water heaters.
__________________

Danny & Linda
Fulltime since '08
2013 Redwood 36FB (FOR SALE)
2013 Denali 3500 DRW D/A
travelin texans is offline   Reply With Quote
Old 04-20-2018, 09:33 PM   #6
Ken / Claudia
Senior Member
 
Join Date: Nov 2012
Location: Gladstone,Ore
Posts: 2,159
Glad to hear it was a easy fix.
__________________
2013 24RKSWE (27ft TT) Cougar 1/2 ton series
2002 Ford F350 4x4 CC 7.3 with aftermarket auto transmisson.
18ft 200hp jet boat.
Yellow Lab "Dacoda"
Retired Oregon State Police
Now a small town traffic cop
Ken / Claudia is offline   Reply With Quote
Old 04-21-2018, 03:40 AM   #7
LongDistanceVoyager
Junior Member
 
Join Date: Apr 2018
Location: Baltimore
Posts: 1
Same problem

I had the same issue with my 25RES first time out. It turned out the circuit breaker in the camp power box was off.
Dave
__________________

LongDistanceVoyager is offline   Reply With Quote
Reply

Tags
power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 02:06 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.