Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Fifth Wheels
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 05-08-2018, 09:58 AM   #1
Scout179
Junior Member
 
Join Date: Nov 2017
Location: Little City
Posts: 27
Ram 3500 question

After about 45 minutes of travel, I start getting warnings that I have an issue with my lighting connection, then to check connection with electrical brakes, then that I have an indictor saying I have brake failure. These warnings change back and forth, then show all is well with no rhyme or reason. I have replaced my trailers connecting cable and replaced squeeze connectors with heat shrink soldiered connectors. Chase vehicle says all lights working while showing failure. I'm thinking it is a vehicle problem and not a connector problem. I've searched older posts, but found nothing.

Has anyone experienced a similar problem? How was it resolved?

My Ram 3500 is a 2017 with less than 3500 miles.
__________________

__________________
Ed & Chris Moore
Keystone Challenger 31RBL
Ram 3500
Little City, Ok

Scout179 is offline   Reply With Quote
Old 05-08-2018, 10:12 AM   #2
kksfish
Senior Member
 
Join Date: Aug 2016
Location: Rincon
Posts: 136
I have had similar issues, warnings that trailer connected or no brakes or lights!

Had dealer try to resolve the problem with no luck! Now I do my pull test when I start and ignore the warnings. I realize it’s not the answer you are looking for but I finally gave up.
__________________

__________________
2017 Ram 3500 CC Cummins
2011 Keystone Laredo 266 RL
kksfish is offline   Reply With Quote
Old 05-08-2018, 10:51 AM   #3
Roscoe
Member
 
Join Date: Mar 2018
Location: Keizer, Or
Posts: 42
Check to see if you have LED lighting on your trailer. I have heard that can cause a light out issue or warning. if you do, you might need an adapter that most all trailer supply shops have them
__________________
Russell & Andrea
2013 Keystone Cougar 279rkswe
2003 Quad Cab Dodge ram 2500 2wd
Edge cs2 Programmer w/ egt
4" Turbo back exhaust
Roscoe is offline   Reply With Quote
Old 05-08-2018, 10:56 AM   #4
Dirtherder
Junior Member
 
Join Date: Feb 2018
Location: N Las Vegas
Posts: 5
I had the same issue. It was a faulty ground connection in the pigtail between the truck and trailer. Check your wire nuts.
Dirtherder is offline   Reply With Quote
Old 05-08-2018, 11:25 AM   #5
Frank G
Senior Member
 
Frank G's Avatar
 
Join Date: Feb 2017
Location: Dade City
Posts: 828
I had that warning once and the plug worked loose. Pulled off the interstate, plugged it in securely and worked fine. I thought it was a nice feature as we were in the hills of Tennessee and could of had a negative outcome had we not known. I have not researched the trigger points but would like to know.
__________________
2017 Laredo 325RL
Travelers Rest Resort
www.travelersrestresort.com
Frank G is offline   Reply With Quote
Old 05-08-2018, 11:35 AM   #6
Racebug
Senior Member
 
Join Date: Mar 2017
Location: Petersburg, KY
Posts: 264
its your trailer wiring more than likely.
__________________

2017 Fuzion 417
2018 Ram 3500 Longhorn
Racebug is offline   Reply With Quote
Old 05-08-2018, 11:51 AM   #7
scuba0331
Member
 
Join Date: Mar 2013
Location: Northeast OH
Posts: 44
Check the connection behind the bumper where the main harness connects to the 7 way plug.
scuba0331 is offline   Reply With Quote
Old 05-08-2018, 12:27 PM   #8
Scout179
Junior Member
 
Join Date: Nov 2017
Location: Little City
Posts: 27
Thanks to all of you! I'll try everything ( it might take awhile) and post my results.
__________________
Ed & Chris Moore
Keystone Challenger 31RBL
Ram 3500
Little City, Ok

Scout179 is offline   Reply With Quote
Old 05-10-2018, 04:36 AM   #9
Scout179
Junior Member
 
Join Date: Nov 2017
Location: Little City
Posts: 27
Update-fyi--I had the Ram at the Dealer yesterday and discussed this matter with the service manager. I was in to have the recall on the pin in the transmission which affected park done. Manager also told me there was a recall on the marker light covers on the roof lights. He says they checked and there were no incidents listed in the computer, so I would need to bring it back with the trailer attached, so they could check it out.
__________________
Ed & Chris Moore
Keystone Challenger 31RBL
Ram 3500
Little City, Ok

Scout179 is offline   Reply With Quote
Old 05-10-2018, 02:45 PM   #10
MarcS
Senior Member
 
MarcS's Avatar
 
Join Date: Jul 2016
Location: Howell
Posts: 581
Quote:
Originally Posted by Scout179 View Post
Update-fyi--I had the Ram at the Dealer yesterday and discussed this matter with the service manager. I was in to have the recall on the pin in the transmission which affected park done. Manager also told me there was a recall on the marker light covers on the roof lights. He says they checked and there were no incidents listed in the computer, so I would need to bring it back with the trailer attached, so they could check it out.
There is a trailer simulator they can hook up and drive around with. Just plugs in. About five inches long and will tell you if trailer is connected, and if every terminal is doing what it is supposed to do.
__________________

__________________
2016 Passport 3350BH
2017 F350 SRW Gasser
MarcS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV® is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 01:32 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.