Go Back   Keystone RV Forums > Keystone Tech Forums > Repairs & Maintenance
Click Here to Login

Notices

Reply
 
Thread Tools Display Modes
 
Old 06-13-2019, 04:42 AM   #1
SAM101814
Junior Member
 
Join Date: Jun 2019
Location: Little Falls
Posts: 15
Slideout lights not working

Hi all,

I have a 2008 Keystone Cougar 29BHS travel trailer with one slideout. The RV is on a permanent site with 30 amp service. The lights on the slideout are not working. I've checked the bulbs, battery, and fuses and all are in good shape. Everything else in the camper works. The AC, heat, fridge, lights in the main cabin, outlets, etc. The lights in the slide out are the only lights not working. I did find the inline circuit breaker on the tongue of my trailer by the battery to be in pretty rough shape (shown in pic). Will replacing this with a new one possibly fix my lights on the slide out? I ordered a 50 amp breaker off of Amazon. I hope it's the right one.https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1
Attached Thumbnails
Click image for larger version

Name:	IMG_20190612_185342380.jpg
Views:	5
Size:	172.6 KB
ID:	22250  
SAM101814 is online now   Reply With Quote
Reply

Tags
slide, slideout, lights, light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV® is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 02:03 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.