Go Back   Keystone RV Forums > Keystone Fleet | Keystone RV Models > Fifth Wheels
Click Here to Login

Reply
 
Thread Tools Display Modes
 
Old 07-17-2018, 06:43 PM   #1
Yewdude
Junior Member
 
Join Date: Jul 2018
Location: Clinton
Posts: 2
No battery power!

I have a 2017 268RLSWE and have some major electrical issues. Before I left home everything worked, but when I got to the camp ground no power to anything but the slide out and awning. We switched the wiring to the same relay as the slide out and awning and everything worked fine. When I got home and went to unhitch, no power whatsoever. When I tried to plug into 110v to keep the fridge cold it kept triggering off my home outlet gfi breaker. I was wondering if anyone out there has had this issue. I am planning on replacing the relays, but there must be another issue that causes them to stop working when I tow. Any advice would be appreciated. Thanks.
__________________

Yewdude is offline   Reply With Quote
Old 07-17-2018, 07:55 PM   #2
bobbecky
Senior Member
 
bobbecky's Avatar
 
Join Date: Jul 2013
Location: Box Elder
Posts: 1,062
Do you have a battery disconnect switch anywhere in the rig? If so the switch is probably turned off, and that would explain why only the awning and slide were working, because they probably do not connect at the power panel, but directly at the battery. The AC power problem could just be too much load on that outlet.
__________________

__________________
Bob & Becky
2012 3402 Montana
2012 Chevy 2500HD D/A CC
bobbecky is offline   Reply With Quote
Old 07-18-2018, 10:38 AM   #3
Yewdude
Junior Member
 
Join Date: Jul 2018
Location: Clinton
Posts: 2
Thanks for your reply. I did check the battery disconnect and still no power.
Yewdude is offline   Reply With Quote
Old 07-18-2018, 01:38 PM   #4
Chief Mole
Senior Member
 
Chief Mole's Avatar
 
Join Date: Jan 2018
Location: Midlands of South Carolina
Posts: 252
SWAG would be that one of the leads on the 120VAC side has grounded or shorted. This would effectively not allow the 120VAC side of the rig to not have power to power the converter, hence no power to anything else including the 120VAC side of the refrigerator. A short or a ground would trip the GFI breaker.
__________________
Bill & Anne, Athena (cat), Jada (pup), and Cupcake (cat)
Retired Navy CPO, Vollie Firefighter and Industrial Maintenance Specialist

Wilson III: 2015 Ram Tradesman 2500 6.4l CC 4x4 SB
the gypsy, Belle III: 2018 Sprinter Limited 3531 FWDEN
Chief Mole is offline   Reply With Quote
Old 07-18-2018, 07:12 PM   #5
Bostongone
Member
 
Join Date: Mar 2017
Location: Ruckersville
Posts: 39
I assume that the trailer has been run off of this house GFCI breaker with no issues prior to this. I am not sure if the 268RLSWE has 30 or 50 amp service but the first thing I would do is to plug it into a non-GFCI protected house circuit. That will help determine if you have a major current fault or a sneaky leakage circuit. If the non-GFCI breaker trips then simply shutting off all the breakers and then turning them on individually until the house breaker trips should find the current fault.

If no breakers trip on the non-GFCI house breaker then you probably have a leakage fault. My guess would be the hot water heater element even if you were still were getting hot water at the campsite.

To diagnose you would need to plug back into the house GFCI breaker and see if it does continue to trip. If it does then with no power to the trailer you need to access the heater element and remove BOTH wires from the heater element by removing the protective cap and removing the screws. With the end of the leads taped for safety turn the house breaker back on and plug the trailer in “hopefully” the breaker will not trip and a new element should fix this issue.

If the GFCI breaker continues to trip then some other AC item must have a leakage fault. You should unplug any AC device where you can access it’s AC plug. I believe the refrigerator can be unplugged by removing the exterior access panel. If this fails to stop the GFCI breaker from tripping you may need some help from a friend who knows some basic AC repair or familiarity because the next step I would do is to go into your AC panel and open each breaker in turn AND lifting the white neutral return from the neutral bar for that AC feed and then apply GFCI power to the trailer. Doing this for each branch should find the “leaky” circuit.

Sorry to be so verbose but if you do have a leakage issue this is I believe the easiest way to find it.
__________________
2008 Springdale 266RELL
2007 Silverado 2500HD crew cab short bed
Bostongone is offline   Reply With Quote
Reply

Tags
battery, power

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by the Keystone RV Company or any of its affiliates in any way. Keystone RV® is a registered trademark of the Keystone RV Company.


All times are GMT -8. The time now is 12:01 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.